fbpx

#excel . São centenas de super planilhas todas com 30% de desconto use nosso cupom: sofman30

EnglishPortuguêsEspañol
0 R$0,00
my cart: 0 item(s)- R$0,00
EmFunção do Excel

Função CONCATENAR

Use CONCATENAR, umas das funções de texto, para unir duas ou mais cadeias de texto em uma única cadeia.

Importante: No Excel 2016, excel mobile e Excel para a Web, essa função foi substituída pela função CONCAT. Embora a função CONCATENAR ainda esteja disponível para compatibilidade com versões anteriores, recomenda-se usar CONCAT de agora em diante. Isso porque a função CONCATENAR pode não estar disponível em versões futuras do Excel.

Sintaxe: CONCATENAR(texto1, [texto2], …)Por exemplo:

  • =CONCATENAR(“População de fluxo para “, A2, ” “, A3, ” é “, A4, “/km”)
  • =CONCATENAR(B2,” “,C2)
Nome do argumento Descrição
texto1    (obrigatório) O primeiro item a ser adicionado. O item pode ser um valor de texto, número ou referência de célula.
Texto2,…    (opcional) Itens de texto adicionais. Você pode ter até 255 itens, até um total de 8.192 caracteres.

Exemplos

Para usar estes exemplos no Excel, copie os dados na tabela abaixo e cole-os na célula A1 de uma nova planilha.

Dados
truta André Gomes
espécies Fourth Pine
32
Fórmula Descrição
=CONCATENAR(“População de fluxo para “, A2, ” “, A3, ” é “, A4, “/km”) Cria uma frase unindo os dados da coluna A com outro texto. O resultado é uma população para espécies de trutas de 32/milha.
=CONCATENAR(B2,” “,C2) Une três coisas: a cadeia de caracteres na célula B2, um caractere de espaço e o valor na célula C2. O resultado é Andreas Hauser.
=CONCATENAR(C2, “, “, B2) Une três coisas: a cadeia de caracteres na célula C2, uma cadeia de caracteres com uma vírgula e um caractere de espaço e o valor na célula B2. O resultado é Andreas Hauser.
=CONCATENAR(B3, ” & “, C3) Une três coisas: a cadeia de caracteres na célula B3, uma cadeia de caracteres formada por um espaço, um E comercial, outro espaço e o valor na célula C3. O resultado é Fourth & Pine.
=B3 & ” & ” & C3 Une os mesmos itens do exemplo anterior, mas usando o operador de cálculo de E comercial (&) em vez da função CONCATENAR. O resultado é Fourth & Pine.

Problemas comuns

Problema Descrição
Aspas aparecem na cadeia de resultados. Use vírgulas para separar os itens de texto adjacentes. Por exemplo: O Excel exibirá =CONCATENAR(“Olá” “Mundo”) como Olá”Mundo com uma aspa extra porque uma vírgula entre os argumentos de texto foi omitida.

Números não precisam ter aspas.

As palavras aparecem misturadas. Sem espaços designados entre as entradas de texto separadas, as entradas de texto serão executadas em conjunto. Adicione espaços extras como parte da fórmula CONCATENAR. Há duas maneiras de fazer isso:

  • Adicione aspas duplas com um espaço entre elas ” “. Por exemplo: =CONCATENAR(“Olá”, ” “, “Mundo!”).
  • Adicione um espaço após o Argumento de texto. Por exemplo: =CONCATENAR(“Olá “, “Mundo!”). A cadeia de caracteres “Olá” possui um espaço extra adicionado.
O erro #NOME? em vez do resultado previsto. #NOME? geralmente significa que estão faltando aspas em um Argumento de texto.

Práticas recomendadas

Siga este procedimento Descrição
Use o caractere & (e comercial) em vez da função CONCATENAR. O operador de cálculo & (e comercial) permite a união de itens de texto sem precisar usar uma função.

Por exemplo, =A1 & B1 retorna o mesmo valor que =CONCATENATE(A1,B1). Em muitos casos, usar o operador E comercial é mais rápido e simples do que usar a função CONCATENAR para criar cadeias de caracteres.

Saiba mais sobre utilizar calculadoras de operação.

Utilize a função TEXTO para combinar e formatar cadeias de caracteres. função Texto converte um valor numérico em texto e combina números com texto ou símbolos.

Por exemplo, se a célula A1 contiver o número 23.5, você poderá usar a seguinte fórmula para formatar o número como um valor em dólar:

=TEXTO(A1,”R$0,00″)

Resultado: R$23,50

EmFunção do Excel

Use a função SOMASE para somar os valores em um intervalo que atendem aos critérios que você especificar. Por exemplo, suponha que em uma coluna que contém números, você deseja somar apenas os valores maiores que 5. É possível usar a seguinte fórmula: =SOMASE(B2:B25;”>5″)

Clique aqui e assista o vídeo!

Dicas:

  • Se quiser, você pode aplicar o critério a um intervalo e somar os valores correspondentes em um intervalo diferente. Por exemplo, a fórmula =SOMASE(B2:B5;”Pedro”;C2:C5) soma apenas os valores do intervalo C2:C5, em que as células correspondentes no intervalo B2:B5 sejam iguais a “Pedro”.
  • Para somar células com base em vários critérios, consulte a função SOMASES.

Importante: A função SUMIF retorna resultados incorretos quando você a usa para corresponder cadeias de caracteres com mais de 255 caracteres ou com a cadeia de caracteres #VALUE!.

Sintaxe

SOMASE(intervalo; critérios; [intervalo_soma])

A sintaxe da função SOMASE tem os seguintes argumentos:

    • intervalo   Obrigatório. O intervalo de células que se deseja calcular por critérios. As células em cada intervalo devem ser números ou nomes, matrizes ou referências que contêm números. Espaços em branco e valores de texto são ignorados. O intervalo selecionado deve conter datas no formato padrão do Excel (exemplos abaixo).
    • critérios   Obrigatório. Os critérios na forma de um número, expressão, referência de célula, texto ou função que define quais células serão adicionadas. Caracteres curinga podem ser incluídos – um ponto de interrogação (?) para corresponder a qualquer caractere único, um asterisco (*) para corresponder a qualquer sequência de caracteres. Para localizar um ponto de interrogação ou asterisco real, digite um til (~) antes do caractere.Por exemplo, os critérios podem ser expressos como 32, “>32”, B5, “3?”, “apple*”, “*~?”, ou TODAY().

      Importante: Qualquer critério de texto ou qualquer critério que inclua símbolos lógicos ou matemáticos deve estar entre aspas duplas (). Se os critérios forem numéricos, as aspas duplas não serão necessárias.

    • intervalo_soma   Opcional. As células reais a serem adicionadas, se você quiser adicionar células diferentes das especificadas no argumento intervalo. Se o argumento intervalo_soma for omitido, o Excel adicionará as células especificadas no argumento intervalo (as mesmas células às quais os critérios são aplicados).Sum_range deve ter o mesmo tamanho e forma que o intervalo. Se não for, o desempenho poderá sofrer, e a fórmula soma um intervalo de células que começa com a primeira célula no sum_range, mas tem as mesmas dimensões do intervalo. Por exemplo:
      intervalo intervalo_soma Células resumidas reais
      A1:A5 B1:B5 B1:B5
      A1:A5 B1:K5 B1:B5

 

Exemplos

Exemplo 1

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Valor de propriedade Comissão Dados
R$ 100.000 R$ 7.000 R$ 250.000
R$ 200.000 R$ 14.000
R$ 300.000 R$ 21.000
R$ 400.000 R$ 28.000
Fórmula Descrição Resultado
=SOMASE(A2:A5;”>160000″;B2:B5) Soma das comissões para valores de propriedades acima de R$ 160.000. R$ 63.000
=SOMASE(A2:A5;”>160000″) Soma dos valores de propriedades acima de R$ 160.000. R$ 900.000
=SOMASE(A2:A5;300000;B2:B5) Soma das comissões para valores de propriedades iguais a R$ 300.000. R$ 21.000
=SOMASE(A2:A5;”>” & C2;B2:B5) Soma das comissões para valores de propriedades maiores que o valor em C2. R$ 49.000

Exemplo 2

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Categoria Alimentos Vendas
Vegetais Tomates R$ 2.300
Vegetais Nabo R$ 5.500
Frutas Laranjas R$ 800
Manteiga R$ 400
Vegetais Cenouras R$ 4.200
Frutas Maçãs R$ 1.200
Fórmula Descrição Resultado
=SOMASE(A2:A7;”Frutas”;C2:C7) Soma das vendas de todos os alimentos na categoria “Frutas”. R$ 2.000
=SOMASE(A2:A7;”Vegetais”;C2:C7) Soma das vendas de todos os alimentos na categoria “Vegetais”. R$ 12.000
=SOMASE(B2:B7;”*s”;C2:C7) Soma das vendas de todos os alimentos que terminam com “s” (Tomates, Laranjas e Maçãs). R$ 4.300
=SOMASE(A2:A7;””;C2:C7) Soma das vendas de todos os alimentos que não têm uma categoria especificada. R$ 400
X
Comece agora
1
Precisa de ajuda?
Equipe sofman
Olá, podemos ajudar?